OpenSSH Server version < 4.4p1 及 8.5p1 <= version < 9.8p1 中的高危root权限远程代码执行漏洞

@Ta 07-02 00:12发布,07-02 10:10修改 4620点击

详细报道:问世近 20 年首个远程执行漏洞,OpenSSH 遭遇新威胁:无需用户交互,可提权至 root

https://m.ithome.com/html/779000.htm


摘要:

近 20 年来 OpenSSH 的第一个高危 RCE

Qualys 威胁研究部门 (TRU) 在基于 glibc 的 Linux 系统中的 OpenSSH 服务器 (sshd) 中发现了一个远程未经身份验证的代码执行 (RCE) 漏洞。分配给此漏洞的CVE为CVE-2024-6387。
该漏洞是 OpenSSH 服务器 (sshd) 中的信号处理程序争用条件,允许在基于 glibc 的 Linux 系统上以 root 身份执行未经身份验证的远程代码执行 (RCE);这带来了重大的安全风险。此争用条件会影响 sshd 的默认配置。

受影响版本:

  • version < 4.4p1
  • 8.5p1 <= version < 9.8p1

如果 sshd 无法更新或重新编译,请在配置文件中将 LoginGraceTime 设置为 0。这会通过用完所有 MaxStartups 连接将 sshd 暴露在拒绝服务中,但它可以防止远程代码执行风险。

Debian已发布紧急安全更新,通过

sudo apt update
sudo apt upgrade
sudo systemctl restart ssh

即可应用安全补丁。

其他发行版请参考各自发行版的安全更新安装方法。

回复列表(17|隐藏机器人聊天)
添加新回复
回复需要登录